"Could not receive any UDP packets for 5.0000 seconds, maybe your firewall is blocking it." with WSL

Hello, I’m using WSL to connect to the polaris vega camera using this pipeline “gst-launch-1.0 rtspsrc location=rtsp://169.254.9.177:554/video latency=1 protocols=1 drop-on-latency=true do-retransmission=false udp-reconnect=false ! rtph264depay! avdec_h264 ! queue ! autovideosink sync=false” but I got this output: Setting pipeline to PAUSED …
Pipeline is live and does not need PREROLL …
Got context from element ‘autovideosink0’: gst.gl.GLDisplay=context, gst.gl.GLDisplay=(GstGLDisplay)“(GstGLDisplayWayland)\ gldisplaywayland0”;
Progress: (open) Opening Stream
Pipeline is PREROLLED …
Prerolled, waiting for progress to finish…
Progress: (connect) Connecting to rtsp://169.254.9.177:554/video
Progress: (open) Retrieving server options
Progress: (open) Retrieving media info
Progress: (request) SETUP stream 0
Progress: (request) SETUP stream 1
Progress: (open) Opened Stream
Setting pipeline to PLAYING …
New clock: GstSystemClock
Progress: (request) Sending PLAY request
Redistribute latency…
Redistribute latency…
Redistribute latency…
Progress: (request) Sending PLAY request
Redistribute latency…
Progress: (request) Sent PLAY request
ERROR: from element /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0: Could not read from resource.
Additional debug info:
…/gst/rtsp/gstrtspsrc.c(5985): gst_rtspsrc_reconnect (): /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0:
Could not receive any UDP packets for 5.0000 seconds, maybe your firewall is blocking it. No other protocols to try.
Execution ended after 0:00:05.723582671
Setting pipeline to NULL …
Freeing pipeline …
The same pipeline executed in the windows environment work correctly, I have no idea about what to do. (I need to manage to let it work to use it with opencv)

For the moment solved by changing the protocol of the pipeline to “protocol=tpc”