Failure with certificate validation while building gstreamer for Windows from source

Hi there,

I need help.

I would like to eagerly try this MR discussed here:

Seungha has greatly helped and implemented new rotation feature.

I’ve checked out that branch, installed meson (using pip as suggested).

Unfortunately I’m getting this certificate check problems from meson (see below image because the forum suppresses links):

I also applied this workaround for this apparent issues with python and certificate validation in Windows:

But that also didn’t fix it.

Any ideas?

Best regards

The python ssl issue on windows is supposed to show as “unable to get local issuer certificate”. In your case it’s “certificate has expired”. Are you sure that your date/time are set correctly?

There is some system configuration issue on your end.

One painful workaround is to download each patch file by hand and put it in subprojects/packagecache

Thanks for getting back. In order to get closer I did a fully fresh install on a new AWS EC2 instance. The issue was that before I tried other work arounds for python and the certificates on Windows I found while googling this. Apparently they were referring to out dated certificates. Unfortunately, as these are tenth of certificates which are installed here I didn’t find a way to remove these once causing the issue from the local Windows certificate store. Worst case I need to reinstall Windows.

It looks like I got a bit rusty building software packages from source. But eventually this worked:

meson setup --vsenv builddir
meson compile -C builddir

Maybe this helps if someone is trying the same

Best regards