Gst-launch-1.0 - no element wpesrc

  • I tried to experiment with the operating system provided gstreamer and custom cerbero built one.
  • No matter what I do, I am keeping on getting: no element “wpesrc”

Inside the cerbero build folder, I do see so files being built cerbero/build/dist/linux_x86_64/lib/x86_64-linux-gnu/gst-plugins-bad/wpe-extension/ and cerbero/build/dist/linux_x86_64/lib/x86_64-linux-gnu/gstreamer-1.0/

  • What can I do to make the sample work ?
  • Is the gst wpe plugin also available on android and ios gstreamer builds ?

I want to make an overlay system for camera video - with an embedded javascript game drawn on top of the video and then streamed to youtube

More than likely you do not have the necessary system libraries. I would start here. An alternative is to use gstcefsrc. However, this option is more heavyweight than wpe due to the use of Chromium/CEF, and I would probably not deploy a solution on a mobile with it (never tried it). At least on linux WPE “requires” wayland (weston, mutter etc…). For iOS/Android you would need a compositor that could be built and run there. I am sure someone has done it, and WPE is pluggable.

1 Like

The gstwpe plugin might be usable on Android, using wpe-android, but I don’t think that was attempted yet.

WPE is not supported on iOS. It’s linux-only.
On iOS you would need a new plugin that would rely on the WebView provided by the OS. The API is not the same as for WPE.