How to resolve syscomp lock down of futex on Android < 11

I’m looking for advice on how to proceed here somewhat because I don’t want to duplicate effort that may already be underway.

It looks like there has (very recently) been made a MR to get a fix into GLib main for older Android devices. The problem surrounds seccomp disallowing a futex syscall for Android < 11 devices. Unfortunately, we need to run GStreamer on devices that old and we’re therefore getting crashes.

I tried to apply the patches linked above directlyin Cerbero but unfortunately GStreamer is on GLib 2.74.4 (Dec 21, 2022) and the patches in the above MR don’t directly apply to the code as-is (at least they didn’t for me). When I tried to pull out the important parts I started running into compilation errors surrounding the use of “__builtin_available”, which makes me think there’s more to do than just copy/paste these patches.

I’m curious if efforts are currently underway to either upgrade the version of GLib to benefit from the recent merger, or if someone has successful .patch files to apply to the 2.74.4 version?

Is this perhaps what you’re looking for?


Hello! I will look tomorrow AM first thing to see if these fix the issue. I appreciate you alerting me to them!