Installation on Rockx Linux 9

I try to install gstreamer on Rocky Linux 9but when I want to start the first Tutorial, I get error messages that the #include <gst/gst.h> file is missing. Any ideas what could be wrong?

Not familiar with Rocky Linux, but I suspect you’re missing the packages with the GStreamer development headers/files.

Not sure what they’re called, perhaps gstreamer1-devel and gstreamer1-plugins-base-devel?

Typing pkg-config --modversion gstreamer-1.0 in the terminal should show a version number.

Hi and thanks for the answer,

This is what I get If i try to install al the packages.

[philipp@philipp ~]$ su
[root@philipp philipp]# dnf install gstreamer1-devel gstreamer1-plugins-base-tools gstreamer1-doc gstreamer1-plugins-base-devel gstreamer1-plugins-good gstreamer1-plugins-good-extras gstreamer1-plugins-ugly gstreamer1-plugins-bad-free gstreamer1-plugins-bad-free-devel gstreamer1-plugins-bad-free-extras
Letzte Prüfung auf abgelaufene Metadaten: vor 5:54:07 am Sa 30 Mär 2024 15:55:00 CET.
Das Paket gstreamer1-devel-1.22.1-2.el9.x86_64 ist bereits installiert.
Das Paket gstreamer1-plugins-base-tools-1.22.1-1.el9.x86_64 ist bereits installiert.
Keine Übereinstimmung für Argumente: gstreamer1-doc
Das Paket gstreamer1-plugins-good-1.22.1-1.el9.x86_64 ist bereits installiert.
Keine Übereinstimmung für Argumente: gstreamer1-plugins-good-extras
Das Paket gstreamer1-plugins-ugly-1:1.22.1-1.el9.x86_64 ist bereits installiert.
Das Paket gstreamer1-plugins-bad-free-1.22.1-2.el9_3.x86_64 ist bereits installiert.
Keine Übereinstimmung für Argumente: gstreamer1-plugins-bad-free-extras
Fehler: Keine Übereinstimmung gefunden: gstreamer1-doc gstreamer1-plugins-good-extras gstreamer1-plugins-bad-free-extras
[root@philipp philipp]# 

[philipp@philipp ~]$ pkg-config --modversion gstreamer-1.0

I tried to install the other packages but it don´ t works.

Then the next question is how exactly are you building the tutorial?


[philipp@philipp GStreamer]$ gcc basic-tutorial-1.c -o basic-tutorial-1 `pkg-config --cflags --libs gstreamer-1.0`

[philipp@philipp GStreamer]$ ./basic-tutorial-1

Now it works… maybe it was because I made a reboot!
Anyway thanks for help!