No element "whipsink "

Hi, i have fresh ubuntu 23.04. I have installed gstreamer with this , but the excelent whip not exist. any clue ?
p.s. the same gst command line run perfect from windows

this is the command:
gst-launch-1.0 rtspsrc location=“rtsp://” latency=0 ! rtph264depay ! avdec_h264 ! clockoverlay ! videoconvert ! videoscale ! video/x-raw,width=640, height=360 ! videoconvert ! queue ! vp8enc deadline=1 ! rtpvp8pay ! queue ! whipsink use-link-headers=true whip-endpoint=“http://localhost:3000

It is highly likely that whipsink is not packaged for Ubuntu 23.04. You will need to build whipsink yourself using the instructions for building in the gst-plugins-rs repository available from: GStreamer / gst-plugins-rs · GitLab

The rust plugins are shipped as part of the official GStreamer binaries for Windows.

Thanks for the reply. I have tried to build as instructed, and it went ok till the last step of

“The plugin can also be installed system-wide:”

in the command line

$ cargo cinstall -p gst-plugin-cdg --prefix=/usr

I receive Error:

CliError failed to create directory ‘usr/lib/gstreamer-1.0’ Permission denied

I have tried some other commands - adding --libdir /usr/lib/x86_64-linux-gnu but it all failed. could you please direct me - what am I missing?

CliError failed to create directory ‘usr/lib/gstreamer-1.0’ Permission denied

For installing into system paths like /usr you need root permissions. Either do that, or install the plugin in the user plugin path, or some other path where you point GST_PLUGIN_PATH to.