No interlace-mode in caps of h264parse

Hello everyone,

I am building a pipeline that receives a TS H.264 stream. What I am trying to do is the following:
depending on the interlace-mode that is present on the caps of the src pad of the parser (h264parse) I want to select a different decoder.

The thing is, interlace-mode is not appearing on the caps, as seen below:

    video/x-h264(memory:SystemMemory) {
        stream-format: (gchararray) "byte-stream",
        width: (gint) 1920,
        height: (gint) 1080,
        framerate: (GstFraction) 30000/1001,
        coded-picture-structure: (gchararray) "field",
        chroma-format: (gchararray) "4:2:0",
        bit-depth-luma: (guint) 8,
        bit-depth-chroma: (guint) 8,
        parsed: (gboolean) TRUE,
        alignment: (gchararray) "au",
        profile: (gchararray) "high",
        level: (gchararray) "4",

Is there any other way to figure out if the video is either interlaced or progressive?

Thanks in advance,

Hey again,

I was able to figure out if the stream is interlaced or not by checking the VideoBufferFlags. Although it works on H265 it does not work for the H264 file that I have.
The only flag that is present in the buffer is the MARKER one.

Here is the output of ffprobe that shows that the video is interlaced, top first:

Could this be an error in the h264parse?